In short
- CVE-2025-27400 is a LOW (CVSS 2.9) vulnerability affecting openmage/magento-lts.
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 17.2% of all vulnerabilities.
- Fix: update to 20.12.3 or later.
Description
As reported by Aakash Adhikari, Github: @justlife4x4, the Design > Themes > Skin (Images / CSS) config field allows a Stored XSS when it contains an end script tag.
Impact
A malicious user with access to this configuration field could use a Stored XSS to affect other authenticated admin users in the admin panel.
The attack requires an admin user with configuration access, so in practice, it is not very likely to be used for gaining elevated privileges, although it could theoretically be used to impersonate other users.
NVD description
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
More vulnerabilities in openmage/magento-lts
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free