In short
- CVE-2025-28254 is a MEDIUM (CVSS 5.4) vulnerability affecting leantime/leantime, leantime (leantime).
- Chance of exploitation in the next 30 days (EPSS): 0.33%, higher than 27.0% of all vulnerabilities.
- Fix: update to 3.3, 3.3.0 or later.
Description
Summary
HTML can be arbitrarily injected into emails from Leantime due to improper neutralization of HTML tags in users' first names. This effectively allows for the creation of phishing emails from a Leantime instance's email address.
NVD description
Cross Site Scripting vulnerability in Leantime v3.2.1 and before allows an authenticated attacker to execute arbitrary code and obtain sensitive information via the first name field in processMentions().
More vulnerabilities in leantime/leantime
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free