In short
- CVE-2025-29868 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/apache/answer, answer (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 62.0% of all vulnerabilities.
- Fix: update to 1.4.5 or later.
Description
Private Data Structure Returned From A Public Method vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.2.
If a user uses an externally referenced image, when a user accesses this image, the provider of the image may obtain private information about the ip address of that accessing user.
Users are recommended to upgrade to version 1.4.5, which fixes the issue. In the new version, administrators can set whether external content can be displayed.
NVD description
Private Data Structure Returned From A Public Method vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.2.
If a user uses an externally referenced image, when a user accesses this image, the provider of the image may obtain private information about the ip address of that accessing user.
Users are recommended to upgrade to version 1.4.5, which fixes the issue. In the new version, administrators can set whether external content can be displayed.
More vulnerabilities in github.com/apache/answer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free