In short
- CVE-2025-30214 is a HIGH (CVSS 7.5) vulnerability affecting frappe, frappe (frappe).
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.8% of all vulnerabilities.
- Fix: update to 15.51.0, 14.89.0 or later.
| Package | Affected versions | Patched versions |
|---|
| frappe PyPI | ≥ 15.0.0, < 15.51.0< 14.89.0
| 15.51.014.89.0
|
| frappe | ≥ 15.0.0, < 15.51.0< 14.89.0
| 15.51.014.89.0
|
Description
Impact
Making crafted requests could lead to information disclosure that could further lead to account takeover.
Workarounds
There's no workaround to fix this without upgrading.
Credits
Thanks to Thanh of Calif.io for reporting the issue
NVD description
Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free