| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.10, < 10.1.40≥ 11.0.0-M2, < 11.0.6≥ 8.5.0, ≤ 8.5.100≥ 9.0.76, < 9.0.104 | 10.1.4011.0.69.0.104 |
| org.apache.tomcat:tomcat-coyote | ≥ 10.1.10, < 10.1.40≥ 11.0.0-M2, < 11.0.6≥ 8.5.0, ≤ 8.5.100≥ 9.0.76, < 9.0.104 | 10.1.4011.0.69.0.104 |
| tomcat | = 11.0.0≥ 10.1.10, < 10.1.40≥ 11.0.1, < 11.0.6≥ 9.0.76, < 9.0.104 | 10.1.4011.0.69.0.104 |
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service.
This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100.
Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free