In short
- CVE-2025-31685 is a CRITICAL (CVSS 9.1) vulnerability affecting goalgorilla/open_social, drupal/social, open social (getopensocial).
- Chance of exploitation in the next 30 days (EPSS): 0.39%, higher than 33.7% of all vulnerabilities.
- Fix: update to 12.4.10, 12.3.11 or later.
| Package | Affected versions | Patched versions |
|---|
| goalgorilla/open_social Packagist | ≥ 12.4.0, < 12.4.10< 12.3.11
| 12.4.1012.3.11
|
| drupal/social Packagist:https://packages.drupal.org/8 | ≥ 12.4.0, < 12.4.10< 12.3.11
| 12.4.1012.3.11
|
| open social | ≥ 12.4.0, < 12.4.10< 12.3.11
| 12.4.1012.3.11
|
Description
Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing. This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.
NVD description
Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing.This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.
More vulnerabilities in goalgorilla/open_social
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free