In short
- CVE-2025-3193 is a HIGH (CVSS 7.5) vulnerability affecting algoliasearch-helper (algolia), algoliasearch-helper.
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.1% of all vulnerabilities.
- Fix: update to 3.11.2 or later.
Description
Versions of the package algoliasearch-helper from 2.0.0-rc1 and before 3.11.2 are vulnerable to Prototype Pollution in the _merge() function in merge.js, which allows constructor.prototype to be written even though doing so throws an error. In the "extreme edge-case" that the resulting error is caught, code injected into the user-supplied search parameter may be exeucted.
This is related to but distinct from the issue reported in CVE-2021-23433.
NOTE: This vulnerability is not exploitable in the default configuration of InstantSearch since searchParameters are not modifiable by users.
NVD description
Versions of the package algoliasearch-helper from 2.0.0-rc1 and before 3.11.2 are vulnerable to Prototype Pollution in the _merge() function in merge.js, which allows constructor.prototype to be written even though doing so throws an error. In the "extreme edge-case" that the resulting error is caught, code injected into the user-supplied search parameter may be exeucted.
This is related to but distinct from the issue reported in [CVE-2021-23433](https://security.snyk.io/vuln/SNYK-JS-ALGOLIASEARCHHELPER-1570421).
**NOTE:** This vulnerability is not exploitable in the default configuration of InstantSearch since searchParameters are not modifiable by users.
More vulnerabilities in algoliasearch-helper
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free