In short
- CVE-2025-32030 is a HIGH (CVSS 7.5) vulnerability affecting apollo gateway (apollographql), @apollo/gateway.
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.9% of all vulnerabilities.
- Fix: update to 2.10.1 or later.
Description
Impact
Summary
A vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. This could lead to excessive resource consumption and denial of service.
Details
Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved.
Fix/Mitigation
A new Query Fragment Expansion Limit metric has been introduced:
- This metric computes the number of selections a query would have if its fragment spreads were fully expanded.
- The metric is checked against a limit to prevent excessive computation.
Patches
This has been remediated in @apollo/gateway version 2.10.1.
Workarounds
No known direct workarounds exist.
References
Query Planning Documentation
Acknowledgements
We appreciate the efforts of the security community in identifying and improving the performance and security of query planning mechanisms.
NVD description
Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.
More vulnerabilities in apollo gateway
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free