In short
- CVE-2025-3454 is a MEDIUM (CVSS 5.0) vulnerability affecting github.com/grafana/grafana.
- Chance of exploitation in the next 30 days (EPSS): 0.46%, higher than 39.8% of all vulnerabilities.
- Fix: update to 0.0.0-20250424191517-1f707d16ed5d or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/grafana/grafana Go | ≥ 0.0.0-20210414170620-dadccdda06e6, < 0.0.0-20250424191517-1f707d16ed5d≥ 0.0.0-20210414170620-dadccdda06e6
| 0.0.0-20250424191517-1f707d16ed5d
|
Description
This vulnerability in Grafana's datasource proxy API allows authorization checks to be bypassed by adding an extra slash character in the URL path.
Users with minimal permissions could gain unauthorized read access to GET endpoints in Alertmanager and Prometheus datasources.
The issue primarily affects datasources that implement route-specific permissions, including Alertmanager and certain Prometheus-based datasources.
NVD description
This vulnerability in Grafana's datasource proxy API allows authorization checks to be bypassed by adding an extra slash character in the URL path.
Users with minimal permissions could gain unauthorized read access to GET endpoints in Alertmanager and Prometheus datasources.
The issue primarily affects datasources that implement route-specific permissions, including Alertmanager and certain Prometheus-based datasources.
More vulnerabilities in github.com/grafana/grafana
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free