In short
- CVE-2025-3573 is a MEDIUM (CVSS 6.1) vulnerability affecting jquery-validation.
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 29.8% of all vulnerabilities.
- Fix: update to 1.20.0 or later.
Description
Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
NVD description
Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
More vulnerabilities in jquery-validation
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free