In short
- CVE-2025-3628 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 27.1% of all vulnerabilities.
- Fix: update to 4.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.5.0-beta, < 4.5.4
| 4.5.4
|
| moodle | ≥ 4.5.0, < 4.5.4
| 4.5.4
|
Description
A flaw has was found in Moodle where anonymous assignment submissions can be de-anonymized via search, revealing student identities.
NVD description
A flaw has was found in Moodle where anonymous assignment submissions can be de-anonymized via search, revealing student identities.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free