In short
- CVE-2025-3930 is a MEDIUM (CVSS 6.3) vulnerability affecting @strapi/strapi.
- Chance of exploitation in the next 30 days (EPSS): 0.69%, higher than 53.0% of all vulnerabilities.
- Fix: update to 5.24.1 or later.
| Package | Affected versions | Patched versions |
|---|
| @strapi/strapi npm | < 5.24.1
| 5.24.1
|
Description
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed). The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack. This issue has been fixed in version 5.24.1.
NVD description
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed).
The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack.
This issue has been fixed in version 5.24.1.
More vulnerabilities in @strapi/strapi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free