In short
- CVE-2025-45691 is a HIGH (CVSS 7.5) vulnerability affecting ragas, ragas (vibrantlabsai).
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.3% of all vulnerabilities.
- Fix: update to 0.3.0-rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| ragas PyPI | ≥ 0.2.3, < 0.3.0-rc1
| 0.3.0-rc1
|
| ragas | ≥ 0.2.3, ≤ 0.2.14
| No fix yet |
Description
An Arbitrary File Read vulnerability exists in the ImageTextPromptValue class in Exploding Gradients RAGAS v0.2.3 to v0.2.14. The vulnerability stems from improper validation and sanitization of URLs supplied in the retrieved_contexts parameter when handling multimodal inputs.
NVD description
An Arbitrary File Read vulnerability exists in the ImageTextPromptValue class in Exploding Gradients RAGAS v0.2.3 to v0.2.14. The vulnerability stems from improper validation and sanitization of URLs supplied in the retrieved_contexts parameter when handling multimodal inputs.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free