In short
- CVE-2025-45769 is a MEDIUM (CVSS 6.5) vulnerability affecting firebase/php-jwt, firebase php-jwt (google).
- Chance of exploitation in the next 30 days (EPSS): 0.15%, higher than 4.0% of all vulnerabilities.
- Fix: update to 7.0.0 or later.
Description
php-jwt v6.11.0 was discovered to contain weak encryption.
NVD description
php-jwt v6.11.0 was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.
More vulnerabilities in firebase/php-jwt
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free