In short
- CVE-2025-46573 is a HIGH (CVSS 8.6) vulnerability affecting passport-wsfed-saml2.
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 31.4% of all vulnerabilities.
- Fix: update to 4.6.4 or later.
Description
Overview
This vulnerability allows an attacker to impersonate any user during SAML authentication by tampering with a valid SAML response. This can be done by adding attributes to the response.
Am I Affected?
You are affected by this SAML Attribute Smuggling vulnerability if you are using passport-wsfed-saml2 version 4.6.3 or below, specifically under the following conditions:
- The service provider is using
passport-wsfed-saml2,
- A valid SAML Response signed by the Identity Provider can be obtained
Fix
Upgrade to v4.6.4 or greater.
NVD description
passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by tampering with a valid SAML response. This can be done by adding attributes to the response. Users are affected specifically when the service provider is using `passport-wsfed-saml2` and a valid SAML Response signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.
More vulnerabilities in passport-wsfed-saml2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free