| Package | Affected versions | Patched versions |
|---|---|---|
| redis | ≥ 7.0, < 7.2.11≥ 7.4.0, < 7.4.6≥ 8.0.0, < 8.0.4≥ 8.2.0, < 8.2.2< 6.2.20 | 7.2.117.4.68.0.48.2.26.2.20 |
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free