In short
- CVE-2025-47287 is a HIGH (CVSS 7.5) vulnerability affecting tornado, tornado (tornadoweb).
- Chance of exploitation in the next 30 days (EPSS): 0.74%, higher than 54.8% of all vulnerabilities.
- Fix: update to 6.5, 6.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| tornado PyPI | < 6.5
| 6.5
|
| tornado | < 6.5.0
| 6.5.0
|
Description
Summary
When Tornado's multipart/form-data parser encounters certain errors, it logs a warning but continues trying to parse the remainder of the data. This allows remote attackers to generate an extremely high volume of logs, constituting a DoS attack. This DoS is compounded by the fact that the logging subsystem is synchronous.
Affected versions
All versions of Tornado prior to 6.5 are affected. The vulnerable parser is enabled by default.
Solution
Upgrade to Tornado version 6.5. In the meantime, risk can be mitigated by blocking Content-Type: multipart/form-data in a proxy.
NVD description
Tornado is a Python web framework and asynchronous networking library. When Tornado's ``multipart/form-data`` parser encounters certain errors, it logs a warning but continues trying to parse the remainder of the data. This allows remote attackers to generate an extremely high volume of logs, constituting a DoS attack. This DoS is compounded by the fact that the logging subsystem is synchronous. All versions of Tornado prior to 6.5.0 are affected. The vulnerable parser is enabled by default. Upgrade to Tornado version 6.50 to receive a patch. As a workaround, risk can be mitigated by blocking `Content-Type: multipart/form-data` in a proxy.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free