In short
- CVE-2025-47708 is a HIGH (CVSS 8.8) vulnerability affecting drupal/miniorange_2fa, miniorange 2fa (miniorange).
- Chance of exploitation in the next 30 days (EPSS): 0.20%, higher than 10.0% of all vulnerabilities.
- Fix: update to 5.2.0, 4.7.0, 8.x-4.7 or later.
| Package | Affected versions | Patched versions |
|---|
| drupal/miniorange_2fa Packagist:https://packages.drupal.org/8 | ≥ 5.0.1, < 5.2.0< 4.7.0
| 5.2.04.7.0
|
| miniorange 2fa | ≥ 5.0.0, < 5.2.0≥ 7.x-2.16, < 8.x-4.7
| 5.2.08.x-4.7
|
Description
The module enables you to add second-factor authentication in addition to the default Drupal login.
The module doesn't sufficiently protect certain routes from Cross Site Request Forgery (CSRF) attacks.
NVD description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Enterprise MFA - TFA for Drupal allows Cross Site Request Forgery.This issue affects Enterprise MFA - TFA for Drupal: from 0.0.0 before 4.7.0, from 5.0.0 before 5.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free