In short
- CVE-2025-47908 is a HIGH (CVSS 7.5) vulnerability affecting github.com/rs/cors.
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.3% of all vulnerabilities.
- Fix: update to 1.11.0 or later.
Description
Middleware causes a prohibitive amount of heap allocations when processing malicious preflight requests that include a Access-Control-Request-Headers (ACRH) header whose value contains many commas. This behavior can be abused by attackers to produce undue load on the middleware/server as an attempt to cause a denial of service.
NVD description
Middleware causes a prohibitive amount of heap allocations when processing malicious preflight requests that include a Access-Control-Request-Headers (ACRH) header whose value contains many commas. This behavior can be abused by attackers to produce undue load on the middleware/server as an attempt to cause a denial of service.
More vulnerabilities in github.com/rs/cors
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free