In short
- CVE-2025-47944 is a HIGH (CVSS 7.5) vulnerability affecting multer.
- Chance of exploitation in the next 30 days (EPSS): 0.81%, higher than 57.0% of all vulnerabilities.
- Fix: update to 2.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| multer npm | ≥ 1.4.4-lts.1, < 2.0.0
| 2.0.0
|
Description
Impact
A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.0
Workarounds
None
References
NVD description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free