In short
- CVE-2025-47949 is a HIGH (CVSS 7.5) vulnerability affecting samlify (samlify project), samlify.
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.7% of all vulnerabilities.
- Fix: update to 2.10.0 or later.
| Package | Affected versions | Patched versions |
|---|
| samlify | < 2.10.0
| 2.10.0
|
| samlify npm | < 2.10.0
| 2.10.0
|
Description
A Signature Wrapping attack has been found in samlify <v2.10.0, allowing an attacker to forge a SAML Response to authenticate as any user.
An attacker would need a signed XML document by the identity provider.
NVD description
samlify is a Node.js library for SAML single sign-on. A Signature Wrapping attack has been found in samlify prior to version 2.10.0, allowing an attacker to forge a SAML Response to authenticate as any user. An attacker would need a signed XML document by the identity provider. Version 2.10.0 fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free