In short
- CVE-2025-48377 is a MEDIUM (CVSS 5.4) vulnerability affecting DotNetNuke.Core, DotNetNuke.Web, dotnetnuke (dnnsoftware).
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.0% of all vulnerabilities.
- Fix: update to 9.13.9 or later.
Description
A specially crafted URL may be constructed which can inject an XSS payload that is triggered by using some module actions.
NVD description
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 9.13.9, a specially crafted URL may be constructed which can inject an XSS payload that is triggered by using some module actions. Version 9.13.9 fixes the issue.
More vulnerabilities in DotNetNuke.Core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free