In short
- CVE-2025-48985 is a MEDIUM (CVSS 5.3) vulnerability affecting ai (vercel), ai.
- Chance of exploitation in the next 30 days (EPSS): 0.28%, higher than 21.0% of all vulnerabilities.
- Fix: update to 5.0.52, 5.1.0-beta.9 or later.
| Package | Affected versions | Patched versions |
|---|
| ai | = 5.1.0< 5.0.52
| 5.0.52
|
| ai npm | ≥ 5.1.0-beta.0, < 5.1.0-beta.9< 5.0.52
| 5.1.0-beta.95.0.52
|
Description
A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade.
NVD description
A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade.
More details: https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free