| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.42≥ 11.0.0-M1, < 11.0.8≥ 8.5.0, ≤ 8.5.100≥ 9.0.0.M1, < 9.0.106 | 10.1.4211.0.89.0.106 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1, < 10.1.42≥ 11.0.0-M1, < 11.0.8≥ 8.5.0, ≤ 8.5.100≥ 9.0.0.M1, < 9.0.106 | 10.1.4211.0.89.0.106 |
| tomcat | ≥ 10.1.0, < 10.1.42≥ 11.0.0, < 11.0.8≥ 9.0.0, < 9.0.106 | 10.1.4211.0.89.0.106 |
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free