In short
- CVE-2025-49007 is a MEDIUM (CVSS 5.3) vulnerability affecting rack, rack (rack).
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 47.9% of all vulnerabilities.
- Fix: update to 3.1.16 or later.
| Package | Affected versions | Patched versions |
|---|
| rack RubyGems | ≥ 3.1.0, < 3.1.16
| 3.1.16
|
| rack | ≥ 3.1.0, < 3.1.16
| 3.1.16
|
Description
Summary
There is a denial of service vulnerability in the Content-Disposition parsing component of Rack. This is very similar to the previous security issue CVE-2022-44571.
Details
Carefully crafted input can cause Content-Disposition header parsing in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. This header is used typically used in multipart parsing. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted.
Credits
Thanks to scyoon for reporting this to the Rails security team
NVD description
Rack is a modular Ruby web server interface. Starting in version 3.1.0 and prior to version 3.1.16, there is a denial of service vulnerability in the Content-Disposition parsing component of Rack. This is very similar to the previous security issue CVE-2022-44571. Carefully crafted input can cause Content-Disposition header parsing in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. This header is used typically used in multipart parsing. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted. Version 3.1.16 contains a patch for the vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free