In short
- CVE-2025-49139 is a MEDIUM (CVSS 6.5) vulnerability affecting haxcms-nodejs (psu), haxcms-php (psu), @haxtheweb/haxcms-nodejs.
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 30.9% of all vulnerabilities.
- Fix: update to 11.0.0 or later.
Description
Summary
In the HAX site editor, users can create a website block to load another site in an iframe. The application allows users to supply a target URL in the website block. When the HAX site is visited, the client's browser will query the supplied URL.
Affected Resources
PoC
- Set the URL in an iframe pointing to an attacker-controlled server running Responder
- Once another user visits the site, they are prompted to sign in.
- If a user inputs credentials, the username and password hash are outputted in Responder.
Impact
An authenticated attacker can create a HAX site with a website block pointing at an attacker-controlled server running Responder or a similar tool. The attacker can then conduct a phishing attack by convincing another user to visit their malicious HAX site to harvest credentials.
NVD description
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, in the HAX site editor, users can create a website block to load another site in an iframe. The application allows users to supply a target URL in the website block. When the HAX site is visited, the client's browser will query the supplied URL. An authenticated attacker can create a HAX site with a website block pointing at an attacker-controlled server running Responder or a similar tool. The attacker can then conduct a phishing attack by convincing another user to visit their malicious HAX site to harvest credentials. Version 11.0.0 contains a patch for the issue.
More vulnerabilities in haxcms-nodejs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free