In short
- CVE-2025-49146 is a MEDIUM (CVSS 5.9) vulnerability affecting org.postgresql:postgresql, postgresql jdbc driver (postgresql).
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 41.9% of all vulnerabilities.
- Fix: update to 42.7.7 or later.
Description
Impact
When the PostgreSQL JDBC driver is configured with channel binding set to required (default value is prefer), the driver would incorrectly allow connections to proceed with authentication methods that do not support channel binding (such as password, MD5, GSS, or SSPI authentication). This could allow a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements.
Patches
TBD
Workarounds
Configure sslMode=verify-full to prevent MITM attacks.
References
NVD description
pgjdbc is an open source postgresql JDBC Driver. From 42.7.4 and until 42.7.7, when the PostgreSQL JDBC driver is configured with channel binding set to required (default value is prefer), the driver would incorrectly allow connections to proceed with authentication methods that do not support channel binding (such as password, MD5, GSS, or SSPI authentication). This could allow a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements. This vulnerability is fixed in 42.7.7.
More vulnerabilities in org.postgresql:postgresql
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free