In short
- CVE-2025-52556 is a CRITICAL (CVSS 9.3) vulnerability affecting rfc3161-client.
- Chance of exploitation in the next 30 days (EPSS): 0.17%, higher than 6.2% of all vulnerabilities.
- Fix: update to 1.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| rfc3161-client PyPI | < 1.0.3
| 1.0.3
|
Description
Impact
rfc3161-client 1.0.2 and earlier contain a flaw in their timestamp response signature verification logic. In particular, it performs chain verification against the TSR's embedded certificates up to the trusted root(s), but fails to verify the TSR's own signature against the timestamping leaf certificates. Consequently, vulnerable versions perform insufficient signature validation to properly consider a TSR verified, as the attacker can introduce any TSR signature so long as the embedded leaf chains up to some root TSA.
Patches
Users should immediately upgrade to rfc3161-client 1.0.3 or later.
Workarounds
There is no workaround possible. Users should immediately upgrade to a fixed version.
NVD description
rfc3161-client is a Python library implementing the Time-Stamp Protocol (TSP) described in RFC 3161. Prior to version 1.0.3, there is a flaw in the timestamp response signature verification logic. In particular, chain verification is performed against the TSR's embedded certificates up to the trusted root(s), but fails to verify the TSR's own signature against the timestamping leaf certificates. Consequently, vulnerable versions perform insufficient signature validation to properly consider a TSR verified, as the attacker can introduce any TSR signature so long as the embedded leaf chains up to some root TSA. This issue has been patched in version 1.0.3. There is no workaround for this issue.
More vulnerabilities in rfc3161-client
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free