In short
- CVE-2025-52662 is a MEDIUM (CVSS 6.1) vulnerability affecting devtools (nuxt), @nuxt/devtools.
- Chance of exploitation in the next 30 days (EPSS): 0.25%, higher than 16.9% of all vulnerabilities.
- Fix: update to 2.6.4 or later.
Description
A vulnerability in Nuxt DevTools has been fixed in version 2.6.4*. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade.
NVD description
A vulnerability in Nuxt DevTools has been fixed in version **2.6.4***. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade.
More details: https://vercel.com/changelog/cve-2025-52662-xss-on-nuxt-devtools
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free