In short
- CVE-2025-53887 is a MEDIUM (CVSS 5.3) vulnerability affecting directus (monospace), directus.
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.4% of all vulnerabilities.
- Fix: update to 11.9.0 or later.
| Package | Affected versions | Patched versions |
|---|
| directus | ≥ 9.0.0, < 11.9.0
| 11.9.0
|
| directus npm | < 11.9.0
| 11.9.0
|
Description
Summary
The exact Directus version number is incorrectly being used as OpenAPI Spec version this means that it is being exposed by the /server/specs/oas endpoint without authentication.
Impact
With the exact version information a malicious attacker can look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version.
NVD description
Directus is a real-time API and App dashboard for managing SQL database content. Starting in version 9.0.0 and prior to version 11.9.0, the exact Directus version number is incorrectly being used as OpenAPI Spec version this means that it is being exposed by the `/server/specs/oas` endpoint without authentication. With the exact version information a malicious attacker can look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version. Version 11.9.0 fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free