In short
- CVE-2025-54417 is a HIGH (CVSS 8.8) vulnerability affecting craftcms/cms, craft cms (craftcms).
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.9% of all vulnerabilities.
- Fix: update to 4.16.3, 5.8.4 or later.
| Package | Affected versions | Patched versions |
|---|
| craftcms/cms Packagist | ≥ 4.13.8, < 4.16.3≥ 5.5.8, < 5.8.4
| 4.16.35.8.4
|
| craft cms | ≥ 4.13.8, < 4.16.3≥ 5.5.8, < 5.8.4
| 4.16.35.8.4
|
Description
NVD description
Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.
More vulnerabilities in craftcms/cms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free