In short
- CVE-2025-54575 is a MEDIUM (CVSS 5.3) vulnerability affecting SixLabors.ImageSharp.
- Chance of exploitation in the next 30 days (EPSS): 0.45%, higher than 39.0% of all vulnerabilities.
- Fix: update to 3.1.11, 2.1.11 or later.
| Package | Affected versions | Patched versions |
|---|
| SixLabors.ImageSharp NuGet | ≥ 3.0.0, < 3.1.11< 2.1.11
| 3.1.112.1.11
|
Description
Impact
A specially crafted GIF file containing a malformed comment extension block (with a missing block terminator) can cause the ImageSharp GIF decoder to enter an infinite loop while attempting to skip the block. This leads to a denial of service. Applications processing untrusted GIF input should upgrade to a patched version.
Patches
The problem has been patched. All users are advised to upgrade to v3.1.11 or v2.1.11.
Workarounds
None.
NVD description
ImageSharp is a 2D graphics library. In versions below 2.1.11 and 3.0.0 through 3.1.10, a specially crafted GIF file containing a malformed comment extension block (with a missing block terminator) can cause the ImageSharp GIF decoder to enter an infinite loop while attempting to skip the block. This leads to a denial of service. Applications processing untrusted GIF input should upgrade to a patched version. This issue is fixed in versions 2.1.11 and 3.1.11.
More vulnerabilities in SixLabors.ImageSharp
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free