In short
- CVE-2025-55558 is a HIGH (CVSS 7.5) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.45%, higher than 39.2% of all vulnerabilities.
- Fix: update to 2.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | < 2.7.1
| 2.7.1
|
| pytorch | ≤ 2.7.0
| No fix yet |
Description
A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of torch.nn.Conv2d, torch.nn.functional.hardshrink, and torch.Tensor.view-torch.mv() and is compiled by Inductor, leading to a Denial of Service (DoS).
NVD description
A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of torch.nn.Conv2d, torch.nn.functional.hardshrink, and torch.Tensor.view-torch.mv() and is compiled by Inductor, leading to a Denial of Service (DoS).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free