| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.syncope.core:syncope-core-spring | ≥ 4.0.0-M0, < 4.0.2< 3.0.14 | 4.0.23.0.14 |
| syncope | ≥ 2.1.0, < 3.0.14≥ 4.0.0, < 4.0.2 | 3.0.144.0.2 |
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free