In short
- CVE-2025-58365 is a HIGH (CVSS 8.7) vulnerability affecting org.xwiki.contrib.blog:application-blog-ui.
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 47.9% of all vulnerabilities.
- Fix: update to 9.14 or later.
Description
Impact
The blog application in XWiki allowed remote code execution for any user who has edit right on any page. Normally, these are all logged-in users as they can edit their own user profile. To exploit, it is sufficient to add an object of type Blog.BlogPostClass to any page and to add some script macro with the exploit code to the "Content" field of that object.
Patches
The vulnerability has been patched in the blog application version 9.14 by executing the content of blog posts with the rights of the appropriate author.
Workarounds
We're not aware of any workarounds.
Resources
NVD description
The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Prior to version 9.14, the blog application in XWiki allowed remote code execution for any user who has edit right on any page. Normally, these are all logged-in users as they can edit their own user profile. For an exploit, it is sufficient to add an object of type `Blog.BlogPostClass` to any page and to add some script macro with the exploit code to the "Content" field of that object. The vulnerability has been patched in the blog application version 9.14 by executing the content of blog posts with the rights of the appropriate author. No known workarounds are available.
More vulnerabilities in org.xwiki.contrib.blog:application-blog-ui
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free