In short
- CVE-2025-58457 is a MEDIUM (CVSS 4.3) vulnerability affecting org.apache.zookeeper:zookeeper, zookeeper (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.2% of all vulnerabilities.
- Fix: update to 3.9.4 or later.
Description
Improper permission checks in the AdminServer allow an authenticated client with insufficient privileges to invoke the snapshot and restore commands. The intended requirement is authentication and authorization on the root path (/) with ALL permission for these operations; however, affected versions permit invocation without that level of authorization. The primary risk is disclosure of cluster state via snapshots to a lesser-privileged client.
- Affected:
org.apache.zookeeper:zookeeper 3.9.0 through 3.9.3.
- Fixed: 3.9.4 (ZOOKEEPER-4964 “check permissions individually during admin server auth”).
- Mitigations:
- Disable both commands (
admin.snapshot.enabled, admin.restore.enabled).
- Disable AdminServer (
admin.enableServer).
- Ensure the root ACL is not open; note that ZooKeeper ACLs are not recursive.
- Upgrade to 3.9.4.
NVD description
Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions.
This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4.
Users are recommended to upgrade to version 3.9.4, which fixes the issue.
The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)
More vulnerabilities in org.apache.zookeeper:zookeeper
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free