In short
- CVE-2025-5891 is a MEDIUM (CVSS 5.3) vulnerability affecting pm2 (keymetric), pm2.
- Chance of exploitation in the next 30 days (EPSS): 0.70%, higher than 53.3% of all vulnerabilities.
- Fix: update to 7.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pm2 | ≤ 6.0.6
| No fix yet |
| pm2 npm | < 7.0.0
| 7.0.0
|
Description
A vulnerability classified as problematic was found in Unitech pm2 prior to 7.0.0. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.
NVD description
A vulnerability classified as problematic was found in Unitech pm2 up to 6.0.6. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free