In short
- CVE-2025-59160 is a LOW (CVSS 2.7) vulnerability affecting matrix-js-sdk.
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.5% of all vulnerabilities.
- Fix: update to 38.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| matrix-js-sdk npm | < 38.2.0
| 38.2.0
|
Description
Impact
matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room.
Patches
The issue has been patched and users should upgrade to 38.2.0.
Workarounds
Avoid using MatrixClient::getJoinedRooms in favour of getRooms() and filtering upgraded rooms separately.
NVD description
Matrix JavaScript SDK is a Matrix Client-Server SDK for JavaScript and TypeScript. matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room. The issue has been patched and users should upgrade to 38.2.0. A workaround is to avoid using MatrixClient::getJoinedRooms in favor of getRooms() and filtering upgraded rooms separately.
More vulnerabilities in matrix-js-sdk
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free