In short
- CVE-2025-60455 is a HIGH (CVSS 8.4) vulnerability affecting max, modular, max (modular).
- Chance of exploitation in the next 30 days (EPSS): 0.33%, higher than 26.6% of all vulnerabilities.
- Fix: update to 25.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| max PyPI | < 25.6.0
| 25.6.0
|
| modular PyPI | < 25.6.0
| 25.6.0
|
| max | < 25.6.0
| 25.6.0
|
Description
Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.
NVD description
Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free