In short
- CVE-2025-61140 is a CRITICAL (CVSS 9.8) vulnerability affecting jsonpath (dchester), jsonpath.
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.6% of all vulnerabilities.
- Fix: update to 1.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| jsonpath | = 1.1.1
| No fix yet |
| jsonpath npm | < 1.2.0
| 1.2.0
|
Description
The value function in jsonpath 1.1.1 lib/index.js is vulnerable to Prototype Pollution.
NVD description
The value function in jsonpath 1.1.1 lib/index.js is vulnerable to Prototype Pollution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free