In short
- CVE-2025-61524 is a HIGH (CVSS 7.2) vulnerability affecting github.com/casdoor/casdoor.
- Chance of exploitation in the next 30 days (EPSS): 0.66%, higher than 51.5% of all vulnerabilities.
- Fix: update to 2.63.0 or later.
Description
An issue in the permission verification module and organization/application editing interface in Casdoor before 2.63.0 allows remote authenticated administrators of any organization within the system to bypass the system's permission verification mechanism by directly concatenating URLs after login.
NVD description
An issue in the permission verification module and organization/application editing interface in Casdoor v2.26.0 and before, and fixed in v.2.63.0, allows remote authenticated administrators of any organization within the system to bypass the system's permission verification mechanism by directly concatenating URLs after login
More vulnerabilities in github.com/casdoor/casdoor
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free