In short
- CVE-2025-62402 is a MEDIUM (CVSS 5.4) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.3% of all vulnerabilities.
- Fix: update to 3.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.1.1
| 3.1.1
|
| airflow | ≥ 3.0.0, < 3.1.1
| 3.1.1
|
Description
API users via /api/v2/dagReports could perform Dag code execution in the context of the api-server if the api-server was deployed in the environment where Dag files were available.
NVD description
API users via `/api/v2/dagReports` could perform Dag code execution in the context of the api-server if the api-server was deployed in the environment where Dag files were available.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free