In short
- CVE-2025-62708 is a HIGH (CVSS 7.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.44%, higher than 38.6% of all vulnerabilities.
- Fix: update to 6.1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.1.3
| 6.1.3
|
| pypdf | < 6.1.3
| 6.1.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter.
Patches
This has been fixed in pypdf==6.1.3.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3502.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter. This has been fixed in pypdf version 6.1.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free