In short
- CVE-2025-64050 is a HIGH (CVSS 7.2) vulnerability affecting redaxo/source, redaxo (redaxo).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 62.0% of all vulnerabilities.
- Fix: update to 5.20.1 or later.
| Package | Affected versions | Patched versions |
|---|
| redaxo/source Packagist | < 5.20.1
| 5.20.1
|
| redaxo | = 5.20.0
| No fix yet |
Description
A Remote Code Execution (RCE) vulnerability in the template management component in REDAXO CMS 5.20.0 allows remote authenticated administrators to execute arbitrary operating system commands by injecting PHP code into an active template. The payload is executed when visitors access frontend pages using the compromised template.
NVD description
A Remote Code Execution (RCE) vulnerability in the template management component in REDAXO CMS 5.20.0 allows remote authenticated administrators to execute arbitrary operating system commands by injecting PHP code into an active template. The payload is executed when visitors access frontend pages using the compromised template.
More vulnerabilities in redaxo/source
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free