In short
- CVE-2025-64112 is a HIGH (CVSS 8.0) vulnerability affecting statamic/cms.
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 23.3% of all vulnerabilities.
- Fix: update to 5.22.1 or later.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | < 5.22.1
| 5.22.1
|
Description
Impact
Stored XSS vulnerabilities in Collections and Taxonomies allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users.
This affects:
- Control panel users with permission to create or edit Collections and Taxonomies
- Versions up to and including 5.22.0
The vulnerability can be exploited to:
- Change a super admin's password (versions ≤ 5.21.0)
- Change a super admin's email address to initiate password reset (version 5.22.0)
- Gain unauthorized access to superadmin accounts
The attack requires:
- An authenticated user with control panel and content creation permissions
- A super admin to view the compromised content
Patches
This has been fixed in 5.22.1.
Credits
Statamic thanks Wojtek Chwala for responsibly reporting the identified issues and working with us as we addressed them.
NVD description
Statmatic is a Laravel and Git powered content management system (CMS). Stored XSS vulnerabilities in Collections and Taxonomies allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This vulnerability is fixed in 5.22.1.
More vulnerabilities in statamic/cms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free