In short
- CVE-2025-64508 is a HIGH (CVSS 7.5) vulnerability affecting bugsink.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.4% of all vulnerabilities.
- Fix: update to 2.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| bugsink PyPI | < 2.0.5
| 2.0.5
|
Description
Impact
In affected versions, brotli "bombs" (highly compressed brotli streams, such as many zeros) can be sent to the server. Since the server will attempt to decompress these streams before applying various maximums, this can lead to exhaustion of the available memory and thus a Denial of Service.
This can be done if the DSN is known, which it is in many common setups (JavaScript, Mobile Apps).
Patches
Patched in Bugsink 2.0.5
NVD description
Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.5, brotli "bombs" (highly compressed brotli streams, such as many zeros) can be sent to the server. Since the server will attempt to decompress these streams before applying various maximums, this can lead to exhaustion of the available memory and thus a Denial of Service. This can be done if the `DSN` is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink version `2.0.5`. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-rrx3-2x4g-mq2h/CVE-2025-64509.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free