In short
- CVE-2025-64761 is a HIGH (CVSS 7.2) vulnerability affecting github.com/openbao/openbao, openbao (openbao).
- Chance of exploitation in the next 30 days (EPSS): 0.39%, higher than 33.1% of all vulnerabilities.
- Fix: update to 2.4.4 or later.
Description
Impact
Similar to HCSEC-2025-13 / CVE-2025-5999, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when:
- An operator in the root namespace has access to
identity/groups endpoints.
- An operator does not have policy access.
Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability.
Patches
Patched in version 2.4.4.
Workarounds
Users should audit the use of identity subsystem and deny operators access if it is not in use.
NVD description
OpenBao is an open source identity-based secrets management system. Prior to version 2.4.4, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: an operator in the root namespace has access to identity/groups endpoints and an operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. This issue has been patched in version 2.4.4.
More vulnerabilities in github.com/openbao/openbao
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free