In short
- CVE-2025-65754 is a MEDIUM (CVSS 6.1) vulnerability affecting github.com/xyproto/algernon, algernon (algernon project).
- Chance of exploitation in the next 30 days (EPSS): 0.44%, higher than 38.2% of all vulnerabilities.
- Fix: update to 1.17.5 or later.
Description
Cross-site Scripting vulnerability in Algernon v1.17.4 allows attackers to execute arbitrary code via injecting a crafted payload into a filename.
NVD description
Cross Site Scripting vulnerability in Algernon v1.17.4 allows attackers to execute arbitrary code via injecting a crafted payload into a filename.
More vulnerabilities in github.com/xyproto/algernon
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free