In short
- CVE-2025-66388 is a MEDIUM (CVSS 6.5) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.4% of all vulnerabilities.
- Fix: update to 3.1.4, 3.1.5 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.1.0, < 3.1.4≥ 3.1.0, < 3.1.5
| 3.1.43.1.5
|
| airflow | ≥ 3.1.0, < 3.1.4
| 3.1.4
|
Description
A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization.
Users are recommended to upgrade to version 3.1.4, which fixes this issue.
NVD description
A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization.
Users are recommended to upgrade to version 3.1.4, which fixes this issue.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free