In short
- CVE-2025-66843 is a MEDIUM (CVSS 5.4) vulnerability affecting getgrav/grav, grav (getgrav).
- Chance of exploitation in the next 30 days (EPSS): 0.16%, higher than 5.4% of all vulnerabilities.
- Fix: update to 1.7.49.5 or later.
| Package | Affected versions | Patched versions |
|---|
| getgrav/grav Packagist | ≤ 1.7.49.5
| No fix yet |
| grav | < 1.7.49.5
| 1.7.49.5
|
Description
grav before v1.7.49.5 has a Stored Cross-Site Scripting (Stored XSS) vulnerability in the page editing functionality. An authenticated low-privileged user with permission to edit content can inject malicious JavaScript payloads into editable fields. The payload is stored on the server and later executed when any other user views or edits the affected page.
NVD description
grav before v1.7.49.5 has a Stored Cross-Site Scripting (Stored XSS) vulnerability in the page editing functionality. An authenticated low-privileged user with permission to edit content can inject malicious JavaScript payloads into editable fields. The payload is stored on the server and later executed when any other user views or edits the affected page.
More vulnerabilities in getgrav/grav
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free